Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Problem with 7950 and Trixx

  1. #1

    Question Problem with 7950 and Trixx

    Hey all,


    I've got the Sapphire 7950 OC edition

    I reinstalled my AMD drivers today and now I'm getting a error message whenever I try to change the voltage in Trixx telling me to disable ULPS. The thing is, it is disabled, I've disabled it completely in the registry. I've tried uninstalling and clearing the leftovers of both the AMD drivers and sapphire utility, but to no avail. It still tells me to disable it and won't let me change any voltages even when I know it's disabled.

    Anyone got any suggestions?

    Thanks

  2. #2
    Join Date
    Sep 2005
    Location
    Joe's Garage
    Posts
    17,664

    Default

    Maybe TrixX needs updating to cater for the newer series of cards ? If you send a report to the techs, they'll look into it for you and see what they can do .. it might mean them having to rework TrixX and the way it works with the newer gen cards ..

  3. #3
    Join Date
    Feb 2012
    Posts
    1,155

    Default

    Hmmmm... That is weird. What versions of the AMD Drivers and TriXX (which is under the "TriXX" logo at the top of the tool) are you using??

    And also while you are at it, mind telling me the specs of the rest of your system??

  4. #4
    Join Date
    Feb 2012
    Posts
    5

    Default

    Same issue here.

    Sapphire 7950 OC edition
    AMD Catalyst™ 12.2 Pre-Certified Driver
    TriXX OC Utility V4.1.0

    Keeps telling me to disable ULPS and restart but I've already done that...and the button is checked to disable it in Trixx settings.

    This is on a fresh install in a new build, just got the card today (so no other/old drivers/versions were ever installed on the comp.).

  5. #5
    Join Date
    Feb 2012
    Posts
    1,155

    Default

    EDIT ADDED: If you did a clean install of the AMD HD 7900 12.2 Pre-Certified Drivers, please look at Post #9 found here: http://www.sapphireforum.com/showthr...904#post235904

    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Yeah this problem is strange since I'm running a HD7950 OC and I haven't experienced the same problem as the two of you. Mind if you two post the complete specs of you systems??
    I'm automatically assuming that the Graphics OverDrive feature on the Catalyst Control Center is disabled.

    But if you two are comfortable dealing with the Windows Registry, you can disable it by opening it, going here:

    HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet001\\Control \\Class\\{4D36E968-E325-11CE-BFC1-08002BE10318}\\0000 (or 000X where "X" is any number)
    Finding "EnableUlps" and setting it's "value data" to "0".

    I didn't do this for the HD7950 per say, but I can confirm that it works for other cards like a CrossFire HD 5850.

    EDIT ADDED: You do not need to touch the "EnableUlps_NA" entry.
    Last edited by EWP; 02-25-2012 at 02:33 AM.

  6. #6
    Join Date
    Feb 2012
    Posts
    5

    Default

    I'll give it a shot. Darkwolf said he already disabled it in the registry itself and it didn't solve the problem

    Antec Solo II case
    Seasonic 460W fanless power supply
    Asus BC-12B1ST blu-ray player
    Intel 320 series 120gb SSD
    Dell U2412M monitor
    Klipsch Promedia 2.1 speakers
    Sennheiser HD 280 headphones
    Intel i5-2500K processor
    Gigabyte Z68X-UD3H-B3 motherboard
    Logitech Illuminated keyboard
    Logitech G9x mouse
    Linksys WRT54GL router
    Canon MX882 printer
    Creative Labs Titanium X-Fi HD soundcard
    Microsoft Windows 7 Home Premium OS
    Antec Truequiet 120mm fans (2)/Scythe pwm
    Thermalright Ultra 120 Rev. C heatsink
    Corsair Vengeance 8gb low profile memory
    Sapphire Radeon 7950 OC edition

    Just copied and pasted my list of parts...
    Last edited by DeeJayeS; 02-25-2012 at 01:49 AM.

  7. #7
    Join Date
    Feb 2012
    Posts
    1,155

    Default

    Quote Originally Posted by DeeJayeS View Post
    I'll give it a shot. Darkwolf said he already disabled it in the registry itself and it didn't solve the problem
    Doesn't hurt to try.

    But if it doesn't work, please list all the hardware/software components of your rig, so we can at least have some understanding of your rig. ^-^ Nevermind. (It also helps to have screenshots of the problem as well.)

  8. #8
    Join Date
    Feb 2012
    Posts
    5

    Default

    Alright, made sure overdrive in Catalyst was unchecked, swapped the registry key to 0 as you suggested for enableulps, made sure disable ULPS in Trixx was checked, rebooted, checked to make sure everything stayed the same, tried Trixx, still gives me the:

    "ULPS is enabled, can't overclock or it will crash the system" message

    grrr...
    Last edited by DeeJayeS; 02-25-2012 at 02:14 AM.

  9. #9
    Join Date
    Feb 2012
    Posts
    1,155

    Default

    I think I finally understand what's going on...

    From what I have read on the latest AMD drivers they didn't add a file that is required for overclocking (atipdlxx.dll). So that's why people who did a clean install with the 12.2 Pre-Cert Drivers are having a hard time. There are two ways of dealing with this, first is to roll back to an earlier driver and then re-install the 12.2 Pre-Cert Drivers without doing a thorough cleaning job, or two download the "atipdlxx.dll" and copy it to the "syswow64" in the "Windows" directory.

    Here is a copy of the "atipdlxx.dll" from the 12.1 RC1 Drivers if you want to do the latter: http://www.mediafire.com/?phl44hvned2pwab
    EDIT ADDED: Here is a link to the RC11 Drivers: http://support.amd.com/us/kbarticles...C11Driver.aspx

    EDIT ADDED: I would also suggest reverting the registry changes that I suggested earlier before you do this.
    Last edited by EWP; 02-25-2012 at 02:15 AM.

  10. #10
    Join Date
    Feb 2012
    Posts
    5

    Default

    Reverted the registry change, downloaded the file, placed it in the folder you said to, made sure disable ULPS was checked in Trixx, rebooted, and....voila. I can now overclock in Trixx. Double-checked in GPU-Z to make sure the numbers matched.

    Problem solved. Thanks a ton--never would have solved it without your expertise!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •